layer 1 phisical/Bit/
2 Data link/frame
3 Packet/network
Type of Communication
Broadcast :1 ke semua
Unicast :1 ke 1
Multicast :1 menerima 1 nggak
IP
class A :1-126,127 contoh: 10.1.100.1 octet format N.H.H.H
B :128-191, : 150.xxx.xxx.xxx octet format N.N.H.H
C :192-223 : 192.xxx.xxx.xxx octet format N.N.N.H
D :224-239 : 225.xxx.xxx.xxx
E :240-255 : 245.xxx.xxx.xxx
Subnet mas untuk mengetahui host
mode dlm switch
1. user mode
Switch>
2. privilage mode
Switch#
3. global configure mode
Switch(config)
Hapus config
maman#delete vlan.dat
maman#erase startup-config
reload
merubah hostname
masuk ke global
Switch(config)#hostname maman-01
memberi pass console
maman-sw-01(config)#line console 0
maman-sw-01(config-line)#password maman
maman-sw-01(config-line)#login
login dengan user pass
maman-sw-01(config)#username maman password maman
maman-sw-01(config)#line
maman-sw-01(config)#line cons
maman-sw-01(config)#line console 0
maman-sw-01(config-line)#login local
maman-sw-01(config-line)#exit
maman-sw-01(config)#
menambahkan ip pada vlan
maman-sw-01(config)#interface vlan 1
maman-sw-01(config-if)#ip add
maman-sw-01(config-if)#ip address 192.168.1.100 255.255.255.0
maman-sw-01(config-if)#no shut
menambahkan telnet
maman-sw-01(config)#line vty 0 2
maman-sw-01(config-line)#pass
maman-sw-01(config-line)#password mamantelnet
maman-sw-01(config-line)#exit
menyimpan config
maman-sw-01# copy running-config sta
maman-sw-01# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
atau
maman-sw-01# write memory
Building configuration...
[OK]
maman-sw-01#
enkripsi password
maman-sw-01(config)#service password-encryption
PORT SECurity
maman-sw-01(config)#interface fastEthernet 0/2
maman-sw-01(config-if)#sw
maman-sw-01(config-if)#switchport sec
maman-sw-01(config-if)#switchport sec
maman-sw-01(config-if)#switchport port
maman-sw-01(config-if)#switchport port-security
maman-sw-01(config-if)#switchport port-security mac-address 00D0.5865.1279.
maman-sw-01(config-if)#switchport port-security violation protect
maman-sw-01(config-if)#
atau
maman-sw-01(config)#interface fastEthernet 0/1
maman-sw-01(config-if)#switchport port-security mac-address sticky ?
H.H.H 48 bit mac address
<cr>
maman-sw-01(config-if)#switchport port-security mac-address sticky vio
maman-sw-01(config-if)#switchport port-security mac-address sticky
maman-sw-01(config-if)#switchport port-security mac-address ?
H.H.H 48 bit mac address
sticky Configure dynamic secure addresses as sticky
maman-sw-01(config-if)#switchport port-security ?
mac-address Secure mac address
maximum Max secure addresses
violation Security violation mode
<cr>
maman-sw-01(config-if)#switchport port-security vio
maman-sw-01(config-if)#switchport port-security violation ?
protect Security violation protect mode
restrict Security violation restrict mode
shutdown Security violation shutdown mode
maman-sw-01(config-if)#switchport port-security
violation res
maman-sw-01(config-if)#switchport port-security violation restrict
cek port sec
maman-sw-01#sh port-security
Secure Port MaxSecureAddr CurrentAddr SecurityViolation Security Action
(Count) (Count) (Count)
--------------------------------------------------------------------
Fa0/1 1 0 0 Restrict
Fa0/2 1 1 0 Protect
----------------------------------------------------------------------
ssh
maman-sw-01(config)#ip domain
maman-sw-01(config)#ip domain-name ?
WORD Default domain name
maman-sw-01(config)#ip domain-name maman.com
maman-sw-01(config)#user
maman-sw-01(config)#username mamanssh pass
maman-sw-01(config)#username mamanssh password mamanssh
maman-sw-01(config)#line vty 0 4
maman-sw-01(config-line)#trans
maman-sw-01(config-line)#transport inp
maman-sw-01(config-line)#transport input ?
all All protocols
none No protocols
ssh TCP/IP SSH protocol
telnet TCP/IP Telnet protocol
maman-sw-01(config-line)#transport input ssh
maman-sw-01(config-line)#login
maman-sw-01(config-line)#login loc
maman-sw-01(config-line)#login local
maman-sw-01(config-line)#cry
maman-sw-01(config-line)#cryp
maman-sw-01(config-line)#crypto key ?
% Unrecognized command
maman-sw-01(config-line)#exit
maman-sw-01(config)#cry
maman-sw-01(config)#crypto ge
maman-sw-01(config)#crypto gen
maman-sw-01(config)#crypto key
maman-sw-01(config)#crypto key ge
maman-sw-01(config)#crypto key generate ?
rsa Generate RSA keys
maman-sw-01(config)#crypto key generate rsa ?
<cr>
maman-sw-01(config)#crypto key generate rsa
The name for the keys will be: maman-sw-01.maman.com
Choose the size of the key modulus in the range of 360 to 2048 for your
General Purpose Keys. Choosing a key modulus greater than 512 may take
a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]
maman-sw-01(config)#
*Mar 1 1:49:20.894: %SSH-5-ENABLED: SSH 1.99 has been enabled
copy IOS dan Configurasi
maman-sw-01#sh flash:
Directory of flash:/
1 -rw- 4414921 <no date> c2960-lanbase-mz.122-25.FX.bin
2 -rw- 1780 <no date> config.text
64016384 bytes total (59599683 bytes free)
maman-sw-01#copy flash tftp
Source filename []? 192.168.1.11
Address or name of remote host []? exit
Destination filename [192.168.1.11]? exit
Writing 192.168.1.11...%Error opening flash:192.168.1.11 (No such file or directory)
maman-sw-01#
maman-sw-01#sh flash
maman-sw-01#sh flash:
Directory of flash:/
1 -rw- 4414921 <no date> c2960-lanbase-mz.122-25.FX.bin
2 -rw- 1780 <no date> config.text
64016384 bytes total (59599683 bytes free)
maman-sw-01#
maman-sw-01#copy
maman-sw-01#copy flash
maman-sw-01#copy flash: tf
maman-sw-01#copy flash: tftp
Source filename []? c2960-lanbase-mz.122-25.FX.bin
Address or name of remote host []? 192.168.1.11
Destination filename [c2960-lanbase-mz.122-25.FX.bin]? maman-sw-01-back-up
Writing c2960-lanbase-mz.122-25.FX.bin...!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 4414921 bytes]
4414921 bytes copied in 0.478 secs (250949 bytes/sec)
maman-sw-01#copy runn
maman-sw-01#copy running-config tftp
Address or name of remote host []? 192.168.1.11
Destination filename [maman-sw-01-confg]? back-up-conf-maman-sw-01
Writing running-config...!!
[OK - 1780 bytes]
1780 bytes copied in 0 secs
Restore flash:
maman-sw-01#copy tftp flash
Address or name of remote host []? 192.168.1.11
Source filename []? maman-sw-01-back-up
Destination filename [maman-sw-01-back-up]?
Accessing tftp://192.168.1.11/maman-sw-01-back-up...
Loading maman-sw-01-back-up from 192.168.1.11: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
[OK - 4414921 bytes]
4414921 bytes copied in 0.424 secs (282909 bytes/sec)
maman-sw-01#sh flash
Directory of flash:/
1 -rw- 4414921 <no date> c2960-lanbase-mz.122-25.FX.bin
2 -rw- 1780 <no date> config.text
3 -rw- 4414921 <no date> maman-sw-01-back-up
64016384 bytes total (55184762 bytes free)
maman-sw-01#
maman-sw-01#dele
maman-sw-01#delete flas
maman-sw-01#delete flash: c2960-lanbase-mz.122-25.FX.bin
^
% Invalid input detected at '^' marker.
maman-sw-01#copy run start
Destination filename [startup-config]?
Building configuration...
[OK]
maman-sw-01#delete
maman-sw-01#delete flash
maman-sw-01#delete flash:
Delete filename []?c2960-lanbase-mz.122-25.FX.bin
Delete flash:/c2960-lanbase-mz.122-25.FX.bin? [confirm]
maman-sw-01#exit
[Connection to 192.168.1.100 closed by foreign host]
C:\>ping 192.168.1.100
Pinging 192.168.1.100 with 32 bytes of data:
Reply from 192.168.1.100: bytes=32 time=1ms TTL=255
Reply from 192.168.1.100: bytes=32 time<1ms TTL=255
Ping statistics for 192.168.1.100:
Packets: Sent = 2, Received = 2, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 1ms, Average = 0ms
C:\>telnet 192.168.1.100
Trying 192.168.1.100 ...Open
User Access Verification
C:\>ssh -l mamanssh 192.168.1.100
Open
Password:
maman-sw-01>en
Password: maman-sw-01#sh flash
Directory of flash:/
2 -rw- 1780 <no date> config.text
3 -rw- 4414921 <no date> maman-sw-01-back-up
64016384 bytes total (59599683 bytes free)
maman-sw-01#
restore configure
maman-sw-01#copy tftp run
maman-sw-01#copy tftp running-config
Address or name of remote host []? 192.168.1.11
Source filename []? back-up-conf-maman-sw-01
Destination filename [running-config]?
Accessing tftp://192.168.1.11/back-up-conf-maman-sw-01...
Loading back-up-conf-maman-sw-01 from 192.168.1.11: !
[OK - 1780 bytes]
1780 bytes copied in 0 secs
maman-sw-01#
----------------------------------------------------------------
- back up : copy flash tftp, copy running-config tftp -
- restore : copy tftp flash, copy tftp running-config -
----------------------------------------------------------------
#perintah back up
terminal length 0
sh ip int br
sh version
sh cdp neighbors
sh cdp neighbors detail
sh run
terminal length 25
0 Comments